Cursor socket help

I’m trying to develop an app (not for webos) that works with websockets. Everything works so far, until I tried to work with the cursor socket. I tried other apps (that worked), debug what they’re sending to the TV and tried to replicate it, but it just doesn’t work for me.
Am I supposed to authorize for this socket too? If yes, how? What format is the message in?
This is the format I’m currently sending: {"type":"button", "name":"MUTE"}
I connect to the socket and send that. Nothing happens.
What am I doing wrong?

In this forum, we only support LG SDK and API issues. Sorry for not being helpful.

Hi, this is API related, but I didn’t see anyone talk about this topic. Do you know anywhere else where I can ask about this?

Sorry for the confusion. We support LG SDK and LG API issues. Thank you.

Ok, well I solved my issue anyway.
If someone else wants to know the solution here it is:
The message isn’t in JSON format. It’s literally type:button\nname:INFO\n\n. That’s an example of pressing the info button. And yes, the 2 newlines at the end are necessary (otherwise it doesn’t work).