Error: All configured authentication methods failed when trying to install app on TV in Developer mode

I’m trying to install an app on the TV through SSH via the WebOS SDK:

ares-install -d webos com.sponty.webos.ipk

and I’m getting the error:

Error: All configured authentication methods failed


ares-install -d webos com.sponty.webos.ipk gives this result

I’ve tried to setup the TV device:

with the privatekey being blank as per the instruction of the user manual under ares-setup-device:

ares-setup-device -a webos -i “username=prisoner” -i “passphrase=7GF9FF” -i “host=” -i “port=9922”

with variation of the privatekey being blank:

ares-setup-device -a webos -i “username=prisoner” -i “privatekey” -i “passphrase=7GF9FF” -i “host=” -i “port=9922”

with privatekey defined

ares-setup-device -a webos -i “username=prisoner” -i “privatekey=” -i “passphrase=7GF9FF” -i “host=” -i “port=9922”

I’ve tried to define the privatekey

ares-setup-device -a webos -i “username=prisoner” -i “privatekey=webos_rsa” -i “passphrase=7GF9FF” -i “host=” -i “port=9922”

what should I do to trouble shoot this?

Please follow the steps in App Testing with Developer Mode App strictly. You don’t need to enter passphrase/privatekey when adding your TV. Thank you.

I followed the instructions in your link and did not input a passphrase and key and I’m still getting the error.

Please share with us the following at

  • OS version of your PC:
  • A screenshot after the step 3 of Turning Developer Mode on.
  • A screenshot that we can see what you entered on the CLI.
  • TV model name: (You can check this in the Settings > General > About This TV.)
  • TV software version:
  • webOS TV version: (This can be found when you click the TV model name in the About This TV menu.)
  • Region:

Thank you for sharing the information. After adding the TV, you should click the Key Server button on the Developer Mode app. Please follow the steps from 5 to 9 in Connecting with CLI. Then, try installing the app again. Thank you.