packed ECONNREFUSED/unpackaged ERR_FILE_NOT_FOUND: failing to get app runing on lg web os simulator

felixolszewski@Felixs-MacBook-Pro-2 SMART TV % ares-install --device emulator "/Users/felixolszewski/Desktop/SMART TV/com.felixolszewski.app1_1.0.0_all.ipk"        
ares-install ERR! [syscall failure]: connect ECONNREFUSED
ares-install ERR! [Tips]: Connection refused. Please check the device IP address or the port number

felixolszewski@Felixs-MacBook-Pro-2 SMART TV % ares-setup-device --list                                                                                                          
name                deviceinfo                connection  profile
------------------  ------------------------  ----------  -------
emulator (default)  developer@  ssh         tv     

felixolszewski@Felixs-MacBook-Pro-2 SMART TV % 

Do I need to link my simulator manually? Or does the emulator device in the list refer to the simulator? If manually: how exactly? I would have no clue what to set as:

  1. name
  2. deviceinfo
  3. ssh
  4. tv

Why do I want to execute this command?

I want to create an app from a static Angular15 website. I also tried simply opening the unpackaged app build folder, as shown in the lg web os tutorial:

But then I got this error when inspecting my app: enter image description here

FAILED TO LOAD RESOURCE: ERR_FILE_NOT_FOUND, for those four filenames: runtimemefa9a14c71368959.js:1 polyfillssc5a6162cac4767e2mjs:1 main.607e420b5eadbc63.js:1 styles.56a9653a72393d06scss:1

Hence I tried deploying the packaged app, as this might resolve the error. But maybe I also have to be able to launch my unpackaged app? If so, then why am I getting the error? I think it could be related to: "Failed to load module script" error on webOS 5+ LG TVs

Can anyone help? I am not too familiar with specifc js/es version things. I could provide my tsconfig.json if necessary.

webOS TV Simulator does not use .ipk. Therefore, the ares-install command is not required. Use only the ares-launch command. For more information, please refer to Test on the Simulator and Launch the app on the Simulator. Thank you.