How to avoid element from being hidden by screensaver

Hello everybody,

I’m developing a video player application. When a user opens the video player in fullscreen, I also draw a box at the bottom of the screen with suggested content that is updated every 30 seconds.

However, in LED TVs, after a while of using fullscreen, the TV starts the screensaver and hides everything that is not the video player, including the box at the bottom. It renders the hidden content as black boxes. Is there any way I can tell the screensaver not to hide the box at the bottom? It is being updated constantly, so it shouldn’t burn the OLED screen. Perhaps adding an special id or using an special HTML tag?

Many thanks

On OLED TVs, Screen Saver always works except while playing a video in the full screen mode. And there is no way to avoid this. Sorry for not being helpful.

Hello @narae0.kim,

No worries, thank you for your answer. I noticed that the screensaver also kicks in even if my video player is not in fullscreen. It basically covers in black everything that is not the video player. Do you know if there is any way we can tell LG that we are/aren’t in fullscreen?

I read in this past reply that you wrote that WebLock is not an official API in WebOS. Do you know if there is any official way to tell the WebOS browser that we aren’t in fullscreen? Perhaps the standard Fullscreen API?

As we said above, Screen Saver always works if a video is not in the full screen mode. So your description is normal operation.

Hi,

There is a very reasonable use case for apps to have non-Fullscreen video. This includes:
a) Showing trailer / previews in upper right
b) Linear video played partial screen so the user can navigate while watching.

We have noticed on services like Netflix and Amazon Prime, even when non-Fullscreen video is playing, the screen saver appears OVER the app fully. However, we do not experience this in our own apps. Instead, the partial screen video player stays visible while the rest of the screen goes black.

Given that we can’t disable the screensaver in code, how can we adapt for this to not have a poor user experience?

  1. Can we detect the screen saver coming on so we can either hide the player so the normal screensaver fireworks appears?
    OR
  2. Can we detect so we can make the partial video Fullscreen?

It is unclear why the behavior is different in Netflix and Amazon Prime.

Making everything else disappear as it does now makes the app feel broken for users.

Thanks for your help.

Can you please share with us the following?

  • TV model name: (You can check this in the Settings > General > About This TV.)
  • TV software version:
  • webOS TV version: (This can be found when you click the TV model name in the About This TV menu.)
  • Region:
  • TV model name: (You can check this in the Settings > General > About This TV.)

This option is not available but it is a 2023 C2 OLED Evo 65 in.

  • TV software version:

I found this in the “support” section and listed as 03.33.65

  • webOS TV version: (This can be found when you click the TV model name in the About This TV menu.)

I believe it is 6.0 since it is a 2023 TV but here is no About This TV menu and cannot find it anywhere.

  • Region: United States

Following up on this. Can you please assist?

Can we please get some feedback on this issue? It has been almost a month since I provided the information you asked for.

Same issue here with video not covering 100% of the screen
I can see the screensaver covering the rest of the page that is not covered by the playing video element.

  • TV model name: OLEDD55BX6LB
  • TV software version: 04.50.53
  • webOS TV version: 5.5.0-1103
  • Region: Italy