Inspector doesn't open on Ubuntu 22.04

I am trying to debug a webOS app on Ubuntu 22.04
I am starting the app on the simulator however the inspector doesn’t open.
There are no errors.

I tried:

  • Launching the inspector from VS Code
  • Launching the simulator from cmd ares-launch -s 22 ./myapp/
  • Pressing inspect on the “remote”
  • Clicking Tools > Inspect
  • Clicking Action > Auto Inspector

Please assist :pray:

Please check if you have set the value of webostv.chromeExecutable property in Settings. For more information, please refer to Set webOS TV Extension. Thank you.

Thank you

I have the value set in my vs code.


Anything else I could check?

Does that mean your app runs on the simulator, but the inspector does not work? If so, please let us know the simulator version. For your information, the v1.3.0 was recently released. Thank you. that is correct. The app starts, but I can’t open the inspector (buttons do nothing).

I tested all versions of the Simulator v1.3.0 on Ubuntu and Mac:

Ubuntu 22.04:

  • webOS TV 23 Simulator - inspector works
  • webOS TV 22 Simulator - inspector does not work
  • webOS TV 6 Simulator - inspector does not work


  • webOS TV 23 Simulator - inspector works
  • webOS TV 22 Simulator - inspector works
  • webOS TV 6 Simulator - inspector works

Seems like there’s an issue with the inspector on Linux on the older versions.

We’ve encountered a similar problem before, and we found that it can be solved by using different versions of Chromium or other browsers. For example, if we’re debugging a web app on a webOS 3.5 TV, we need to open the inspector link on Chromium Version 68.0.3440.0 or older. When we debug the same app on newer webOS versions, we use the latest browsers with Chrome-based engines.

I hope this information is helpful.

Sorry for the inconvenience and the late reply. Currently, only the webOS TV 23 Simulator supports Ubuntu 22.04 and higher. We will update the document soon. Sorry again and thank you for your report.