Subject: Error with LG webOS API on newer TV (webOS 7.2.0)

Hi all,

I am facing an issue with the LG webOS API when making a request to my own service on my new LG TV despite the fact that the same code was working fine on an older LG TV.

window.webOS.service.request("luna://com.customservice/", {
      parameters: {name: "app"},
      onFailure: handleWebosDiscoveryFailure,
      onComplete: res => handleWebosDiscoverySuccess(res)

I get the following response:

response: {
      returnValue: false,
      errorCode: -1,
      errorText: 'Service does not exist: com.customservice.'



  • My SDK version is 7.2.0-43 (mullet-marine)
  • firmwareVersion: 03.21.25
  • modelName: 43UQ7590PUB
  • webOSTV lib version: 1.2.4
  • My new LG TV has the latest software update.

Has anyone else encountered this issue on newer LG TV models or have any suggestions for how to resolve it? I would greatly appreciate any help or guidance you can provide.
Thanks in advance!

Please refer to Hello World Service sample app. This app demonstrates how to create a webOS TV service and works without issues. Thank you.

Hello, I opened the sample app in the webOS IDE and I’m running it in on my TVs and the service is not working on neither the new LG TV nor the old LG TV.

Does something need to be done to activate the service? I simply brought the projects into the webOS IDE and tried to debug.

As you can see in the images below, the service ID and the app ID does match (although it appears that in this sample, the serviceID has a .service at the end)

We double checked that the sample app works on the webOS TV 22. Please make sure the app directory and service directory are packaged together into an .ipk file. You can refer to Packaging JS service. If the problem persists, please share your .ipk file at Thank you.

Thank you for your response.
I packaged the app and service successfully and the .ipk file was created. However, when I run the app on my new 43UQ7590PUB LG TV, it still fails to call the service.
I sent a copy of the directory along with the .ipk file to the email you suggested.

Hello, is there any update on this? Thank you.

Sorry for the late reply. We checked your .ipk several times, but it works without issues. Please check the CLI version with the ares-v command first. And please check if the service is installed properly with the following command:

ares-novacom -d DEVICE -r "ls -la /media/developer/apps/usr/palm/services/" 
ares-novacom -d DEVICE -r "ls -la /media/developer/apps/usr/palm/services/com.sample.helloworld.service"

If the problem persists, please reset the settings in Settings > General > System > Reset to Initial Settings menu and try again.